Win10安装Scrapy报错的解决方法

今天想测试下爬虫框架,于是就pip进行安装发现报错,看下面提示

error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http://landinghub.visualstudio.com/visual-cpp-build-tools

看上面感觉好像是需要安装vc++14,于是网上找了下,没有14的版本只有13或者15,于是折腾了下13和15都装了,还是报错,再仔细查看报错上面一句提示

building 'twisted.test.raiser' extension

想想会不会是这个原因,于是就是去找twisted模块离线先安装了再试着安装爬虫框架

下载twisted模块,以下是下载地址

https://download.lfd.uci.edu/pythonlibs/r5uhg2lo/Twisted-18.9.0-cp37-cp37m-win_amd64.whl

然后进入这个文件目录

pip install Twisted-18.9.0-cp37-cp37m-win_amd64.whl

安装完以后我们再安装爬虫框架,就可以很顺利的完成安装

pip install scrapy

安装完以后我们可以使用以下命令打印出版本信息

scrapy version

menu.saveimg.savepath20190108113633.jpg

内容版权声明:除非注明,否则皆为本站原创文章。

转载注明出处:http://sulao.cn/post/631.html

我要评论

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。